Daily Archives April 23, 2021

OK, I’m still dealing with the error problem I’m getting on my new Canon EOS R6, but I think I may have a found a solution, or a culprit, or some way of moving forward (here’s the link for more on this “Err 70” problem I’m having which shuts my camera down during my shoot).

1. Could it be a compatibility issue with my new Tamron lens?

There was a compatibility issue early on with the EOS R6 camera body and certain Tamron lenses (including my new SP 150-600mm G2 lens). So, I contacted Tamron and they checked my lens’ serial number and were able to confirm it already has the firmware update that makes it compatible with the Canon EOS R6, so it’s not that. They did offer to have me send in the lens and they would inspect all the connections and such (no charge), but I don’t think that’s the issue, so unless I hit a road block and that’s the only possible solution, I won’t need to be shipping the lens to them. High-five to Tamron for the awesome customer service either way.

2. What about my Canon EOS R6’s firmware?

This is what I think the most likely culprit is. I checked my new R6’s firmware version and even though I just got the camera recently, it was still on the original 1.0 firmware. It’s now up to firmware version 1.3.1 and I found an article where it mentions the err 70 issue, and that this addresses it. I also heard from a reader who said his err 70 issue went away after he updated his firmware, so yesterday I updated the camera’s firmware to the latest (1.3.1), and I’m hoping it fixes the issue. More on this as I keep shooting with it, but I’m hopeful.

3. Another scary possibility

I also heard from a repair tech who used to work full-time as a Canon tech guy, and he said,

…the error you experience (error 70) is almost always due to a defective main board in the camera. The camera may work on and off but the problem will always return, often the problem correlates to a defective memory buffer or issues within the mainboard related to power (think EOS Rebel 70D). The only way to get rid of it is to send to Canon for service.”

I hope that’s not the case, but at least since he said that, I’m mentally prepared to send the unit back if need be, but I’m hoping my updating the firmware to 1.3.1 will have done the trick. I’ll let you know if it doesn’t.

Thanks to everyone who has offered suggestions and tried to help me figure this out. There’s not many photographers out there experiencing this issue, so while it’s not widespread, it certainly is frustrating, but I will get it figured out and get back to enjoying the R6. Outside of “Err 70” it is, hands-down, the best camera I’ve ever used by far, and I am super digging it. All the more reason why I want to get it working right. :)

Have a great weekend, everybody! Wishing you good heath and happiness. :)

-Scott

Close